SQL Server Performance

SQLMail on Multiple SQL instances

Discussion in 'General DBA Questions' started by jfou, Nov 26, 2002.

  1. jfou New Member

    Hi all,

    On a server MSSQL 2000 having two SQL instances, I don't manage to configure SQLMail on one instance. On this instance, I have the message of mistake according to when I configure under Enterprise Manager the MAPI profile:
    Error 18030: xp_test_mapi_profile : Either there is no default mail client or the current mail client account cannot fulfill then messaging request. Please run Microsoft Outlook and set it as the default mail client.

    Remarks :

    • I use the same account (SQLServer) of starting for all the SQL services of each instance.
    • I configured the MAPI profile used by Outlook XP logged to Windows 2000 with the SQLServer account. Outlook XP is the default mail client.

    Sorry for my poor English...

    Thank you for your help.



    Jean-Paul FOURNIAUD
  2. satya Moderator

  3. jfou New Member

    Thank you for your answer. I consulted the KBA that you sent to me, but nothing has permitted me to make operate SQLMail on my second SQL instance.

    I summarize my situation:

    • I have a server Exchange 5.5 named R7 (Windows 2000 Advanced Server SP2S).
    • I have a server MSSQL 2000 (SP2) named X1 (Windows 2000 Advanced Server SP2S).
    • On server X1, I have :
      Two SQL instances : X1 and X1Asset.
      The SQL services (MSSQLServer, MSSQL$Assets, SQLServerAgents, and SQLAgent$Asset) are all started with the account of DOMAINSQLServer service.
    • Outlook 2002 configured with a profile (ProfSQL) for the DOMAINSQLServer account.

    My problem:

    • Under Enterprise Manager, when I configure SQLMail :
    • For the process SQL X1Asset, in the properties of SQLMail, I see the ProfSQL profile in the dropdown list and the click on the button 'Test' functions well.
    • For the process SQL X1, in the properties of SQLMAill, I don't see the ProfSQL profile in the dropdonw list and the click on the button 'Test' return a mistake 18030.


    Thank you


    Jean-Paul FOURNIAUD
  4. satya Moderator

    YOu need to reconfigure mail client for this instance also, thats why error is self-explanatory.

    HTH

    Satya SKJ
  5. gtupper New Member

    It looks like you may not be grabbing the correct mapi profile. Here are some simple steps to walk through to see if everything is configured properly.
    1. I would recommend logging into the server as the domain account. Once in double click on the outlook 2000 program and verify that you can send and recieve an email.
    2. Now open up enterprise manager and go to the properties of the x1 server. go to the server settings tab and verify the sql mail mapi account located towards the bottem of the page. You could hit the change button to see what other mapi profiles are available and can also hit the test button to ensure that it is setup correctly.
    3. Now open up the Agent properties. On the general tab you will see the mail session properties again. Again verify that the profile is correct. Now click on the test button to ensure that it is working properly.
    4. Now you will need to check under the support services folder and get the properties on the sql mail icon. You will once again need to verify the profile and can click on the test button.
    5. Now repeat these same steps for the x1asset server.

    You will also want to verify the startup accounts on the General tab of the agent properties. If you get any errors on any of the above steps it will not work.

    Greg

Share This Page