SQL Server Performance

[sqsrvres] ODBC sqldriverconnect failed

Discussion in 'SQL Server Clustering' started by akothand, Jul 13, 2006.

  1. akothand New Member

    One of my cluster services keeps failing when started using a Cluster account "Cluster_SVC".But, if i start the service with my account it runs.
    Both accounts are "sa", have "Login as service" option in Local security policy.
    This is a SQL 2000 cluster.
    The event viewer shows the SQL server is starting up proper, says "Recovery complete" for all databases and then this message shows :
    [sqsrvres] ODBC sqldriverconnect failed

    SQL cluster service is terminated then, causing the resources to go offline

    Any inputs?

    Thanks

    Thanks,
    Anand.K

    Purity, patience, and perseverance are the three essentials to success
    and, above all, love - Swami Vivekananda
  2. dineshasanka Moderator

    is this the problem

    http://support.microsoft.com/kb/307336/

    ----------------------------------------

  3. akothand New Member

    Thanks mate..this was the issue

    Thanks,
    Anand.K

    Purity, patience, and perseverance are the three essentials to success
    and, above all, love - Swami Vivekananda
  4. satya Moderator

    After the cluster installation has the servername changed anytime?
    Refer to this KBAhttp://support.microsoft.com/default.aspx?kbid=328306 to get more information on resolving the issue.

    Also check the default named-pipe settings from Server network utility.l

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided �AS IS� with no rights for the sake of knowledge sharing.

Share This Page