SQL Server Performance

SSIS Package not running as JOB

Discussion in 'SQL Server 2005 Integration Services' started by danny123, Jun 17, 2008.

  1. danny123 New Member

    Hi there,
    I have a SSIS package which is running fine at my dev machine but when i install it on production server and try to run it as sql job it gives me following error:
    "Executed as user: Company_Domainsql_service. ....00.3042.00 for 64-bit Copyright (C) Microsoft Corp 1984-2005.
    All rights reserved.
    Started: 5:03:50 PM Error: 2008-06-17 17:03:50.59 Code: 0xC0016016
    Source:
    Description: Failed to decrypt protected XML node
    "DTS:password" with error 0x8009000B "Key not valid for use in specified state.".
    You may not be authorized to access this information.
    This error occurs when there is a cryptographic error.
    Verify that the correct key is available.
    End Error
    Error: 2008-06-17 17:03:50.59
    Code: 0xC0016016
    Source:
    Description: Failed to decrypt protected XML node "DTS:password" with
    error 0x8009000B "Key not valid for use in specified state.".
    You may not be authorized to access this information.
    This error occurs when there is a cryptographic error.
    Verify that the correct key is available.
    End Error Progress: 2008-06-17 17:03:51.02
    Source: Copy Company Availability table
    Validating... The package execution fa... The step failed."
    I have all the database connections with sql server logins and passwords. I have tried running the job with my credentials as i am admin on the server did not work. Then i tried running the package with sa password and i got same error.
    Thanks
    Danny
  2. satya Moderator

  3. danny123 New Member

    Hi there,
    Thanks for the help. The link provided helped me resolve my issue. This is what i had to do to fix the issue:
    "I had the same problem and was able to resolve it by changing how I stored the package protection level when saving the package to SQL server. Only when saving the package to SQL server did it allow me to change this option. In DTS designer it will not let you save the package with a protection level of ServerStorage. Who knows why as this is just a designer with a deployment option. Anyways:

    - Select File > Save Copy of <package> As
    - The bottom box is greyed out called protection level. Click on the weird box with a dot in the middle on the right and a dialog will pop-up.
    - Change the package protection level to the last option "Rely on server storage and roles for access control"

    This allows any one with access to execute the package defined by SQL server roles to run the package. "
    Best
    Danny

Share This Page