SQL Server Performance

Strange Litespeed behaviour

Discussion in 'Third Party Tools' started by marat, Feb 6, 2008.

  1. marat New Member

    Hi,
    I am trying to restore litespeed SQL2000 backup on SQL2005 using litespeed(actually this was a working procedure which fails recently).
    When I am trying to verify backup file from SQL2005 connection it returns error:Msg 61000, Level 19, State 0, Line 0
    ThreadID: 0, Invalid size found: 1254945
    A nonrecoverable I/O error occurred on file "VDI_B0537BF1-DB68-471A-8653-54A832777865_0:" 995(error not found).
    VERIFY DATABASE is terminating abnormally.
    If I run verification of the same file from SQL2000 it is successful.
    Did anybody had the same experience?
    Thank you
    marat
  2. satya Moderator

    Welcome to the forum!
    How big is the database?
    Have you referreed in Quest site (forums) for this issue?
    Since you are getting a I/O error on that drive, have you tried the same backups on two or more different drives?
    For sure this sounds like a hardware disks problem better to check with vendor.
  3. marat New Member

    Database is about 60G.
    I was thinking of faulty disk, but SQL standard restore works fine; problem is only with Litwspeed.Also, how to explain different verification results on SQL Server 2000 and 2005 for the same backup file?
    I will try to get to Quest Forums.
  4. satya Moderator

    The verification you can do with SQL such as VERIFYONLY will check whether it can access the backup file or not, for internal verification you can achieve by running DBCC CHECKDB only and even that is not reporting any issues it could be problem with the disks when a particular write-intensive process is initiated.
    Using SYSMON (PERFMON) counters for physical disk, cpu & memory would help you to asses the issue in detail.
    As you purchased tool from Quest it is better to invovle them as you may have support arrangements.
  5. marat New Member

    PS. Standard MS SQL Backup and Restore worked fine.
  6. satya Moderator

    That should work and have you performed CHECKDB and disk verification in this case?

Share This Page