SQL Server Performance

Strange permissions issue with A/P Cluster

Discussion in 'SQL Server Clustering' started by burningcoals, Sep 27, 2005.

  1. burningcoals New Member

    I have been running an Active / Passive cluster for some time now. Over a year with no issues.

    About 3 months ago our SQL batch upgrade scripts started failing, we would get the following error;

    [Shared Memory]SQL Server does not exist or access denied.
    [Shared Memory]ConnectionOpen (Connect()).

    But the SQL Services run just fine, I can failover the nodes just fine. One thing that is strange is when I login under an account with admin rights I am unable to change the Autostart policies, they are all greyed out.

    Everything seems to work fine , I can connect remotely through Query analyzer, etc.

    Another strange thing is when I go to update a service pack it will complain that it can't find my virtual instance.

    I believe the Cluster service, MSSQLSERVER service, and Agent service are all using the same DOMAIN account.

    Anyone have any ideas or suggestions?

    OS: Windows 2003 Server ENT
    SQL Version. 2000 SP3a

    Thanks
    -Shaun
  2. satya Moderator

  3. burningcoals New Member

    Thanks Satya,

    I have already searched that KB and it does not apply to my situation.

    I have a live server that is accessed daily by over 100 people who are working in it. There is no connectivity problems whatsoever.

    I can connect remotely or locally.

    The strange thing really is why I am unable to change the autostart policies, they are all greyed out. I have never seen that before.

    The shared memory error I get comes only when I run a SQL batch file on the local server.

    Do you know why for some reason the Autostart policies would be greyed out and I am unable to change them on my SQL server, I am unable to select Autostart MSSQLSEVER, Autostart MSDTC or Agent. Is that normal in clustered configurations?

  4. satya Moderator

    Ensure you're using administrator account in order to enable those AUTOSTART policies.
    Also try with cluster administrator account.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  5. Argyle New Member

    You can and should not change the autostart options on a cluster. They are handled by the cluster itself. Control all stop/start actions through cluster administrator and no other way.
  6. burningcoals New Member

    Thanks for the help!

    I found my problem. I guess I cant change the autostart policies since its a cluster and controlled through CAdmin.

    My problem was a bug in the code that I was using.

    On non-clustered servers, you can use OSQL -S and not specify the Virtual instance or SQL server name and it will login just fine. On clusters you must specify the Instance name for SQL or OSQL will not be able to login.

    There was a spelling error in the SQL scripts that was not displaying the correct variable for the server, so I would get an shared memory access denied error.

  7. mulhall New Member

    Just further to your point on OSQL -S, burningcoals;

    There is no 'default' instance in clusters, which gives you the OSQL behaviour and will explain other connectivity issues.

Share This Page