SQL Server Performance

Transactional Replication subscriptions fails to catchup with transactions evafter re-initialization

Discussion in 'SQL Server 2008 Replication' started by chetanjain04, Aug 22, 2011.

  1. chetanjain04 Member

    I have a subscription which is not catching up with latest transactions from publisher even after being re-initialized successfully with latest snapshot of publication.

    After I re-initialize, I can see the snapshot generate for all articles and its distribution complete successfully and during that time the tables are in sync.

    But after a couple of days the subscriber is not having latest data. As of now, the distribution agent is showing 'no replicated transactions are available'. Also there are 0 undistributed commands. The most strange thing is that there are two subscribers to this publication and out of that only one of them is having this problem.

    I verified all the errorlogs of sql server, checked the mssubscriptions whether the subscription is active and confirmed that we are not having any space issues or inactive subscriptions. I am unable to understand this behaviour of replication. If any one out there, seen such issues in past or have any suggestions do let me know.
  2. satya Moderator

    Did you check the replication monitor to see if there are any warnings generated for this behaviour.
  3. Hrishi_nk New Member

    Hey can u set the replication using TSQL .
    Because i have encountered such kind of problems when i had set replication using GUI.
  4. satya Moderator

    Yes you can, using the Management Studio once you had setup the articles you can choose to script out the option to a new query window or even generate script at the end of the wizard.

Share This Page