SQL Server Performance

Transactional Replication - Uninitialized Subscription Error

Discussion in 'SQL Server 2005 Replication' started by dannielg, Aug 3, 2007.

  1. dannielg New Member

    Hi,
    We have a production server which replicates around 200 odd databases to the reporting server and we are in thr process of upgrading to SQL 2005. And while upgrading and settingup the replication only for 16 databases we are getting an error saying "Uninitialized Subscription". We are usng PULL SUBSCIRPTION and when we tried with PUSH it is working fine.
    This is a kind of show stopper for us in migrating to production.
    Any help would be much appraciated.
    Thanks
    Danniel
  2. MohammedU New Member

    Remove and recreate subscriptions and see....
  3. dineshasanka Moderator

  4. ustun New Member

    I am using SQL Server 2005 Standard Edition as a publisher and Express as a subscriber for snapshot replication. I tried to set up pull subscription to distribute the load. However, I am getting the "uninitialized subscription" warning and the data is not transferred to the subscriber. Reinitializing does not work. One other thing is, while I am trying to configure the subscription I saw that the only schedule option to run the subscription is "Run On Demand Only". Does this mean that Express Edition only supports On Demand Pull Subscription?
  5. satya Moderator

  6. ustun New Member

    I am using snapshot replication. I upgraded to MS SQL Server Standard Edition for the subscriber side and I got "Run Continuously" option from drop-down menu somewhere in configuration. However, I have the same warning and tables are not pulled.
    Replication monitor says that uninitialized subscription warning and no info comes up when I double click on it.
    Now I guess snapshot and pull may not work together, because I don't remember that I saw an option to tell the subscriber how to pull the data (like a schedule for instance)..

    Anyway, thanks for the comments and sharing your knowledge.


  7. satya Moderator

  8. Hello,
    We are using Enterprise edition and configured transactional replication. Configuration, Creation of publication and subscriptions every thing went fine without error. But receiving UNINITIALIZED SUBSCRIPTION warning. Tried to re-initialize the subscriptions but no luck. As per above steps i have dropped and re-created subscription as well but still no luck.. Any suggestions greatly appreciated.
    Regards
  9. satya Moderator

    Welcome to the forums.
    From the replication monitor as you can see the value for Performance critical, Expiring soon/Expired, and Uninitialized subscription are warnings. When a warning is displayed, the Status column also displays if an agent is running. For example, the status could be Running, Performance critical. So confirm whether you see any value in Status column.
    Also see http://msdn.microsoft.com/en-us/library/ms151320(v=sql.90).aspx fyi.
  10. Thank you sir.
    Under "Warnings and Agents" tab Status column is showing as
    Status Job
    "Never Started" - 'Snapshot Agen'
    "Never Started" - 'Log Reader Agent'
    More over i have double clicked on warning and a dialog box was open. Nothing is showing for Status column under "Publisher to Distributor History" and "Distributor to Subscriber History" tabs.
    Issue is not yet solved.
    Regards,
  11. satya Moderator

    Can you check whether Replication agents are up and running?
    I believe this could be agent start up issue.

Share This Page