SQL Server Performance

Unable to connect to Report Manager

Discussion in 'SQL Server 2008 Reporting Services' started by sani, Aug 2, 2010.

  1. sani New Member

    Hi all, I have recently installed SQL Server 2008 Reporting Service but unable to connect to report manager. I got the following error:
    The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.
    This error occurred while connect to: http:///reports but when I use http:///reportserver, it will show SYS1 and Users Folders. At first I have installed SQL Server 2005 Reporting Service and Engine but as We need to have latest version, I have uninstalled it and installed SQL Server 2008 Reporting Service and Engine.

    Is this the root cause of the problem?
    Also Database engine and Reporting service has the same version. I used the same name for installation.
    And have added the URL in rsreportserver.config as follows but I got the same error

    <UI>
    <ReportServerUrl>
    http://<server name>/reports
    </ReportServerUrl>
    <PageCountMode>Estimate</PageCountMode>
    </UI>

    <UrlRoot>http://<server name>/reports</UrlRoot>.


    Any idea will be greatly appreciated. Sani.
  2. satya Moderator

    What is the operating system used?
    See further information on the error from
    Program FilesMicrosoft SQL ServerMSSQL.1Reporting ServicesLogFiles directory.

    Further you can also
    edit the file C:program FilesMicrosoft SQL ServerMSSQL.1Reporting ServicesReportManagerRSWebApplication.config and add the full url to the ReportServer into the ReportServerUrl tag (no ending / nessesary) AND remove the value from ReportServerVirtualDirectory and recycle the app-pool.

  3. sani New Member

    Thank sfor the reply
    In Log file, I see some information like https://<server name>/reports/ReportService2005.asmx but I am using Reporting Service 2008. I don't know why it shows ReportService2005.asmx.
    Is this usual or it should be 2008 instaed of 2005? Is this information related to the first reporting service installation which was 2005? many be the uninstall process has not been completely done?
    Sani.
  4. satya Moderator

    Did you see the SSRS2005 service under Control panel --> Admin.tools --> Services pane?
  5. dineshasanka Moderator

Share This Page