SQL Server Performance

unc path

Discussion in 'SQL Server 2005 Integration Services' started by arkiboys, Jan 4, 2010.

  1. arkiboys Member

    Hi,
    My package uses the UNC i.e. the full path in the foreach loop container which works fine.
    When scheduling this package as a job, it seems that it runs but nothing happens.
    I have narrowed down the problem and it seems the problem is definitely to do with the path.
    How can I solve this please?
    Thanks
  2. FrankKalis Moderator

    Does the account that runs SQL Server Agent have permissions to access this location?
  3. arkiboys Member

    yes because it is using my account
  4. MohammedU New Member

    Try using the FQDN fully qualified domain for server name/ip address...
    or
    Try to run the job under your account instead using SQL Agent account and make sure you can access the path from the server where SQL is running.
  5. arkiboys Member

    Hello MohammedU,
    I do use the full UNC path.
    The owner of the job shows "domainmyusername".
    In the job step properties under Run as: it shows "SQL Agent Service Account". There is no other option to change this to.
    Any thoughts on that please?
    Thanks
  6. MohammedU New Member

  7. FrankKalis Moderator

    [quote user="arkiboys"]
    yes because it is using my account
    [/quote]
    Okay, but is the job step also executed under your security context?
  8. arkiboys Member

    Hello FrankKalis,
    I checked the properties of the Job.
    In the owner section under General page, it shows "domainmyusername"
    In the job step properties under Run as: it shows "SQL Agent Service Account". There is no other option to change this to.
    Do you mean I should try to change this to something else?
    Thanks

Share This Page