8624 Internal SQL Server Error | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

8624 Internal SQL Server Error

We just moved to a new server. It’s 64 bit, 4 dual core x64 processors, 64 bit OS. Multi-threading is enabled, so it appears as 16 processors. We don’t have licenses for SQL 2005 yet, so we had to stick with SQL 2000. Apparently you can’t install 64 bit SQL Server 2000 on an x64 box…only itanium 64 bit. So, we have 32 bit sql on it. It told us in the install process that for that version, we had to use sp4. I put sp4 on and everything has been fine until I tried yesterday to run a process that we run quarterly. It worked fine on the old box (32 bit, 4 procs, sp3a), but gives the Internal SQL Server Error now. It doesn’t even break down in the same spot every time. I haven’t been able to find anyone having the same problem. I’m not including the code because it’s thousands of rows of code and it can’t be pinpointed to any one spot. It’s just a series of update statements. Some of them are dynamic sql that are based on the parameters sent to the sproc. Bottom line, it worked on the old box, but doesn’t work now.
Check these
All says to update SP4, htofixes and critical updates
http://www.windowsitpro.com/Article/ArticleID/42234/42234.html —————————————-

The articles that you sent me are things that are supposedly fixed in sp4. The one about referencing views inside of views with a lot of joins etc….I had run into that with sp3a a couple of times, but that is not the issue here. I’m not referencing any views. I’ve been doing some more research and it seems that there are others who have had issues with sprocs working on sp3a and not working after upgrading to sp4. I think a Microsoft support call is pending. I’m just hoping there’s a hotfix for this. Please let me know if anyone else has seen anything like this. Thanks,