Change transaction safety mode | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Change transaction safety mode

I am using SQL 2K5 standard with sp2 and am testing db mirroring (no withness). Because our two servers are in a workgrouop, I set up the database mirroring using TRANSACT SQL statements not the management studio tool. It is working fine that way. By default, transaction safety is set to FULL which is sychnronous. The options are grayed out in the db’s mirroring properties window. How do I change it to OFF which is asynchronous. The BOL shows me that I can issue "ALTER DATABASE <database> SET PARTNER SAFETY OFF" on the principal server but when I issue the statement, I got an error "This SQL Server edition does not allow changing the safety level. ALTER DATABASE command failed.". Please advice. Wingman
Only in EE of sql server 2005 Asychronous mirroring is available…
SE option synchronous onl you can’t change it… See the features document…
SQL Server 2005 Features Comparison MohammedU.
Moderator All postings are provided “AS IS” with no warranties for accuracy. fyi.l Satya SKJ
Microsoft SQL Server MVP
Writer, Contributing Editor & Moderator
This posting is provided AS IS with no rights for the sake of knowledge sharing. The greatest discovery of my generation is that a human being can alter his life by altering his attitudes of mind.