Difficult times deploying a few packages to SQL Se | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Difficult times deploying a few packages to SQL Se

Hi Guys! I have created a big list of packages, some calling others. They all work fine from my computer using Visual Studio. When I try to deploy them (building them with deployment turned on and running them either directly from Management Studio or as a job) I get the errors with the password of connection strings. From what I read so far its the encryption process that kills it. I have tried to add a password to some packages, but it still didnt work (only when run directly on my computer in management studio after deploying to SQL Server, but not as a job). I have tried to change ProtectionLevel to SecurityStorage, wouldnt let me save in Visual Studio (I understand it is ot allowed in VS because you are saving to File System, how the hell am I supposed to save it to anything else? why is it showing there if its not even valid?). If anyone can please give me the steps to doing it properly, that would be awesome. I simply need to run the packages from SQL Server! thats all! I have no idea why it has to be soooo difficult :/ Would really appriciate your help in the matter! [^] Guy
Please specify the error text for those packages with the problem.
Also check the privileges for the SQLAgent account that is used for scheduled jobs. Satya SKJ
Microsoft SQL Server MVP
Contributing Editor & Forums Moderator
This posting is provided AS IS with no rights for the sake of knowledge sharing.