Disk Resource Not Present in Cluster Administrator | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Disk Resource Not Present in Cluster Administrator

I am new to MS and SQL clustering so please bear with me.
We had an existing 2 node Windows 2003 Enterprise x64 and SQL 2005 (default instance) cluster connected to a SAN (S:) data drive and a SAN (Q:) quorum drive. I recently added another node to the Windows cluster that has connections to the original SAN S: drive and Q: drive as well as another SAN data drive (R: separate data volume). When I attempted to install an additional instance of SQL 2005 to reside on the R: drive, I get to the point in the installation to select the resource group (also created a new SQL Server Group) I receive the message that there is no Physical Disk drive available in the New SQL Server group. I have tried to create a new resource for the R: drive in the Cluster Administrator but there is no drive resource to select, or move into the new SQL Server group. I am attempting to create an Active/Active/Passive Cluster the the original Active Node and the New Active Node can both fail over to the Passive node. Do I need to create a connection to the new Data Volume (R:) on all nodes in order for the Physical Disk Resource to appear in the Cluster Administrator? I am stuck right now unable to complete the SQL Server install for the new instance until I can get this resource to appear in the Cluster Administrator. I have been unsuccessful so far in locating information on making this resource available. Any help would be greatly appreciated.
Thank You,

Did you add the R: drive as a dependency for the SQL Server service in Cluster Administrator?

No as I was not able to create an R: drive resource. However I have since added the R: drive resource by connecting all nodes to the SAN R: drive. It was then available when creating a new resource. Should I have a SQL Server service for each instance of SQL? Also with the Active/Active/Passive scenario should I select all 3 nodes during the install or just the new node and the passive node? I started the SQL 2005 installation again (from the active node)and this time was able to select the new SQL Server Group that I created since it now had the R: drive resource in it. Is the installation supposed to be installed from the active node, or on the new (3rd node)? Setup failed in the final stage this time.
The summary.txt shows an error on the new node and two failures and ten successes.
New node Error message:
An installation package for the product Microsoft SQL Server Native Client cannot be found. Try the installation again using a valid copy of the installation package sqlncli.msi
New node Fail message:
An installation package for the product Microsoft SQL Server NativeClient cannot be found. Try the installation again using a valid copyof the installation package sqlncli.msi
Error Number: 1706
Passive Node Fail message:
Error number: 1603 No message

I would think that the passive node would have a service for each instance. My two-node active/active has this on each node.
It sounds like what you are trying to do is almost like having two seperate clusters that share the same passive node. If they are all in the same cluster, how are you defining which node the instances are to fail-over to?
Also, I’m assuming that the new instance would have to be installed on the new 3rd node. If you try to install it on the passive node of the existing cluster, the installation will know this and think you’re doing a reinstall of some kind.
Granted, I’ve never tried what you’re describing, and I’m not completely sure if you can install two different instances on the same cluster and set them to fail-over to the same node.

Okay, I "think" I have this working. I guess sometimes writing out questions gives you ideas on new things to try. I went ahead and ran the SQL install on the new 3rd node and chose the existing passive node of the original cluster as the 2nd node for the install of the new instance. The installation went through and all the SQL Services installed successfully, until the very end I received a message that setup failed. When I looked through the summary.txt log file it shows that 3 of the components failed. I have listed them below.
Machine: New Node
Product: SQLXML4
Install: Failed
Error Number 1620
Machine: New Node
Product: Microsoft Visual Studio 2005 Premier Partner Edition
Install: Failed
Error Number 1620
Machine: New Node
Product: Microsoft SQL Server 2005 Books Online
Install: Failed
Error Number 1620
However the above components all showed up as if already installed. I ran the setup (msi) files on each of these components individually after the SQL install and they all completed successfully. Does this mean that they are in fact installed? Should I re-run the SQL setup again and let it pick these up in order to have a clean log?
In the Cluster Administrator all the SQL services show up as resources in the new cluster group. On the new server (node) the SQL services are all running with the new instance name. How can I be sure this is functioning properly?
When trying to connect to to the DB from Management Studio I receive a message that SQL Security restricts remote connections and denies the connection. What do I have to do to connect to this to ensure it is working?
Can you please respond to each of these questions with any insight you may have? These are probably stupid questions but I have to learn somehow.
Thanks again for all your previous responses and I look forward to learning more.

As far as VS 2005 and Books Online are concerned, you most likely have these configured on your management/development workstation, so not having them installed on the server is that big of a deal. Not sure about SQLXML4, though, but my guess is that they are fully installed now anyways.
The sure-fire way to make sure the new instance is operating is to connect through Management Studio. The "restricts remote connections" error is usually bogus, and is most likely caused by trying to connect to the wrong instance. What machine are you trying to connect from? Are you able to connect to it from the node itself? My guess is you’re just not connecting to the correct instance name.

You are right. I was unable to connect because I was typing the virtual SQL Server name only. From the new node itself, I installed Mgmt Studio and received the same bogus message. However when I browsed, I located the correct database in the "VirtualSQLDNSNameInstanceName" format and viola I connected.
Problem resolved!!!!!! Hooray!
Thanks for all your suggestions.


Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |