dts fail – please help | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

dts fail – please help

Hello there ! I am trying to import a medium size table about 1300*600 flat file into the sql server 2005 using dts, but it gives out error "Not enough storage is available to complete this operation". dts works with small table though.
Any help will be highly appreciated
Do you have enough space on MDF file. have you MDF auto growth option? —————————————-
Contributing Editor, Writer & Forums Moderator
http://www.SQL-Server-Performance.Com Visit my Blog at

it should be auto grow option issue with SQL 2005. else if with sql 2000 check outhttp://support.microsoft.com/?kbid=889170 Deepak Kumar
MVP, MCDBA – SQL Server Disclaimer: This post is provided as is with no rights & warranty for accuracy, for the sake of knowledge sharing only.
Also check the relevant column name are matching when using DTS, as there are few issues with backward compatibility using DTS in SQL 2005. Satya SKJ
Microsoft SQL Server MVP
Writer, Contributing Editor & Moderator
This posting is provided AS IS with no rights for the sake of knowledge sharing. The greatest discovery of my generation is that a human being can alter his life by altering his attitudes of mind.
Thanks Dineshasanka,deepakontheweb and satya I do have enough space on harddisk. mdf and ldf files are set to autoincrease by 10%, moreover I tried by making mdf size 5 times, but did not work. Also column names are ok. I have been using this dts file before even with large tables, I didnot have any problem until it happen a few days ago suddenly. Is it because I have large number of columns- 600 columns ….?? any other thoughts !!
also I dont have any problem importing the same table from the xls format.
It just does not work with txt/csv flat file. I am going crazy by this behaviour of the dts
Are you using dts or ssis?
Is it scheduled? MohammedU.
The following thread is related to 2000…it may apply to 2005 also… http://www.thescripts.com/forum/thread83616.html
I am using dts not ssis and also it is not scheduled
It does not work even with the import/export wizard from the enterprise manager thanks
Did you check the thread mentioned …
http://www.thescripts.com/forum/thread83616.html MohammedU.
Thanks MohammedU, I think the explanation given by the link is right.
Seems the dts is taking each column as varchar(8000).
I could not find way to change it to some lower number right in dts in the server although it can be easily done in dts.bas but not easy to import back it to server again. Anyway, I think my problem is solved now, thank you to all guys for your time to my problem.