enable full text search | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

enable full text search

Hi, I’m trying to enable full text indexing on a table. The context menu item for Full-Text Index Table is disabled so I ran EXEC sp_fulltext_database ‘enable’ and got the error Server: Msg 7602, Level 16, State 2, Procedure sp_fulltext_database, Line 46
The Full-Text Service (Microsoft Search) is not available. The system administrator must start this service.
The configuration for my server is as follows: Microsoft SQL Server 2000 – 8.00.760 (Intel X86)
Dec 17 2002 14:22:05
Copyright (c) 1988-2003 Microsoft Corporation
Enterprise Edition on Windows NT 5.0 (Build 2195: Service Pack 4)
Both the MSSQLSERVER and the Microsoft Search services are set to start automatically.
Microsoft Search runs as LocalSystem account
MSSQLSERVER runs as a dedicated domain account
Full-Text search is installed
I really don’t want to re-install SQL server unless I absolutely have to. Please help.

Hi ya, In Enterprise Manager under the server’s Support Services presumably FullText Search has been started? If so, then I’d err towards reinstalling the search part of SQLServers. The following steps is what I’ve had to do in the past for a different problem with Search -Open regedit.exe
-Rename the key HKLMSoftwareMicrosoftMSSQLServerTrack[E07FDDA7-5A21-11d2-9DAD-00C04F79D434] by placing an x or something before it
-Run the SQL Server installation program and reinstall MSSearch (the above key governs whether the install program thinks MSSearch is installed)
-Now reapply any service packs and hotfixes
-Rebuild and repopulate the Full-Text catalogues Cheers
quote:Originally posted by Twan In Enterprise Manager under the server’s Support Services presumably FullText Search has been started?

Well the problem is Full Text Search is just not showing up under Support Services. However, it should be installed because:
1. I started the installer again and the search component is checked already.
2. The Microsoft Search service is in the list of services and is started.
3. HKEY_LOCAL_MACHINESOFTWAREMicrosoftSearch1.0ApplicationsSQLServer is in the registry. I’ve tried restarting the machine and still it won’t show up.
Any ideas? This is driving me insane! Thanks,
The following section is from SQL Server 2000 Books Online:
"After changing the SQL Server service account information in Control Panel, you must also change the SQL Server service account in SQL Server Enterprise Manager. This allows the service account information for Microsoft Search service to remain synchronized as well. Important: Although the Microsoft Search service is always assigned to the local system account, the full-text search engine tracks the SQL Server service account in Windows. Full-text search and failover clustering are not available if Windows password changes are not reset using SQL Server Enterprise Manager."
… articles for your referenc.e Satya SKJ
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.