error 7391 New transaction cannot enlist | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

error 7391 New transaction cannot enlist

Hi all, I am having the two servers and
both are having win2k3 sp1 and MS SQL SEREVR 2000. I have configured linked serevr on bothe the servers and DTC is enabled on both the servers.
when I fire a query from server like insert into [].manoj.dbo.username values (‘manoj’,’india’); this query works fine but when I execute the same query with begin distributed transaction tag like

begin distributed tran
insert into [].manoj.dbo.username values (‘manoj’,’india’);
commit tran

this is giving the following error
Server: Msg 7391, Level 16, State 1, Line 2
The operation could not be performed because the OLE DB provider ‘SQLOLEDB’ was unable to begin a distributed transaction.
[OLE/DB provider returned message: New transaction cannot enlist in the specified transaction coordinator. ]

what can be wrong ?? please respond.. I am in great need of a solution. thanks in advance
Verify that the OLE DB provider specified supports distributed transactions. If the provider does not support distributed transactions, rewrite the data modification statement not to use distributed transactions. KBA fyi. Satya SKJ
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.;en-us;889706 also provide more information
Lots of info in these forums: On Windows 2003 you also need to perform the following: In Windows 2003 Service Pack 1 you also have new security options for MSDTC. Once you’ve followed the above links then go to: Administrative Tools -> Component Services -> Console Root -> Component Services -> Computers -> Right-click My Computer and select Properties -> Click the MSDTC tab -> Click the Security Configuration button -> Check Network DTC Access. You might have to select "No Authentication Required" on the Transaction Manager Communication option as well in the same window. Restart the MSDTC service on both servers after.
Is it valid to use an IP address? I ran into this error when the linked server couldn’t resolve the originating server’s domain name. Try to add each server’s name to the hosts file on the other server and try using the host name, that solved the issue for me.