Executing Parameterised Stored Procedures | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Executing Parameterised Stored Procedures

Hello Friends, I am trying to create a report using a parameterised stored procedure. The procedure executes successfully in the Data tab when we select the Dataset by prompting for the parameter value, but in the preview page I get the following error- "This parameter is not a parameter for the stored procedure". Ravi
Are you trying to do a batch update? Satya SKJ
Moderator
http://www.SQL-Server-Performance.Com/forum
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
Hi, No I am using a stored parameterised procedure in the SQL Server Reporting Services Beta version.
However, I got thru the problem. What I was doing was taking the value of the report parameter same as the parameter in the query, this was giving me an error – " Forward referencing of parameters is not allowed". For this I created a new dataset which was given as a source to the report parameter and it worked. Any way thanxs to one and all. Bye, Ravi
Glad it worked and appreciate for the interest to post the workaround. Satya SKJ
Moderator
http://www.SQL-Server-Performance.Com/forum
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
]]>

Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |