Full Text Index Won't Populate | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Full Text Index Won’t Populate

I looked around but none of the suggestions worked so far. Here is my environment:
SQL Server 2000 Sp3a Std Ed
Win2003 box
dbs with full-text index turned on.
The following accounts have local pc admin and SQL server sys admin privileges :
Account that runs SQL Service
Everything is great except that when I try to populate the full-text index the population successfully starts but it never ends and the item count is always 0. No blocks on sp_who. No errors.
I#%92m scratching my head since the same setup on a different server works just fine…

Solution found.
This problem was related to a server issue: "The procedure entry point GetTextExtentPointI could not be located in the DLL MSDART.dll’ This bug originated from an upgrade as detailed in the threadhttp://www.mcse.ms/message99060.html
here is the solution:
On a machine running Windows 2003 Server that was upgraded from Windows 2000 Server, look for OLEDB32.DLL in ‘c:program FilesCommon FilesSystemOle DB’. Check the version of OLEDB32.DLL. If it is the correct version for Windows 2003 Server, it should be (at least) version 2.80.1022.0 according to the MDAC 2.8 manifest. On my servers that were upgraded from Windows 2000 Server to Windows 2003 Server, that OLEDB32.DLL file was version 2.71.9042.0. The wrong version. I copied the OLEDB32.DLL that was version 2.8.1022.0 to c:program
FilesCommon FilesSystemOle DB on the upgraded machines, and it seems to have solved the problem.