Integration Services installed in 2008 Developer Edition but getting message I need to install it. | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Integration Services installed in 2008 Developer Edition but getting message I need to install it.

Microsoft Visual Studio is unable to load this document.
To design Integration Services packages in Business Intelligence Development Studio, Integration Services has to be installed by one of these editions of SQL Server 2008: Standard, Enterprise, Developer, or Evaluation. To install Integration Services, run Sql Server setup and select Integration Services.
In the first place, the initial install created the Integration Services piece. During that process, I got a warning about my firewall and a message that a temporary internet file could not be found. I found something about port numbers. I enabled port 135.
I tried the setup suggestion (with the option to add to the existing product) but found that nothing could be selected. I.S. was already installed. I cancelled the setup.
I downloaded and ran hot fix SQLServer2008-KN960484-x86, but it told me that nothing applied to any of my software.
I downloaded the latest Books Online (May 2009). I then restarted the setup and selected the repair option. That ran fine (I.S. Passed) except for the same firewall warning and Management Tools – Basic Failed.
The reason I am trying to use the software is to load a table in SQL Server 2008 Express from SQL Server 2008 Developer via SSIS.
Now I don’t know what else to do. Can anyone please help me? Thanks.

what exactly you wants, I mean to say to transfer the table or software installtion problem
Thank you,

Thanks Sandy for your concern. I tried to provide all needed info and I guess I failed to state the exact problem. Actually, I think I have figured out why the problem exists and maybe how to solve it. But I wish for your comments.
When I run the Discovery Report for the setup, it tells me that IS is part of the Developer edition (that’s good). But it also shows that IS is not part of any Instance (as opposed to Analysis Services and Reporting Services, which are part of the MSSQLSERVER instance). That might mean that IS is in a shared group. (I’m not too knowledgeable on some parts of SQL Server.) I don’t know if that is good or bad.
The problem I am having is that I get an error message (saying that IS needs to be installed) even though IS seems to be installed already. I think the problem is that when I installed the Express Edition, IS (a "hollow" version) showed up as if it were a part of the total software package. When I tried to run IS in the Express version, I got the message about IS needing to be installed. I searched the internet and found someone’s wonderful post that said that IS really is not loaded with Express (and that Microsoft really should not even show the little icon on the screen). That prompted me to check more. I then found out that I could buy the Developer edition for $50. I bought it and loaded it to my PC.
I think that when the Developer edition loaded, it saw a version of IS (the "hollow" version) and did not reload IS from the Dev CD. Now, when I try to run IS, I think the hollow version is being invoked, and that version is connected to Express (and therefore, will not run).
When I tried to repair the Dev. version, I was unable to select IS, and so, nothing changed.
I think my solution is to drop Express and then see if I can add IS to Dev. version. If that works, I can re-download Express and move forward. If that doesn’t work, I will have to drop Dev. and start all over by doing a new install of Dev. That should load IS properly. Then I can re-download Express. If I have any trouble at that point, I will drop Express permanently.
Does this sound like a good plan to you? Any comments are welcomed. Thanks.

My problem has been solved. At first I tried to uninstall (via the Vista uninstall-a-program software) parts of Express, but that didn’t solve the problem. I even manually deleted the Report folders on my C: drive. After much trial and error, I finally decided to quit "learning" (I enjoy experimenting) and start over. For that approach, I uninstalled all of Express and all of Developer. I checked the PC for ancililary files/folders. I then installed Developer from scratch from the DVD. This time I understood a little more of the options I had to choose from. The install went well. Integration Services worked. I was able to make a SSIS package and drop a Data Flow task on it. I rebooted just for grins. I downloaded the updates for Dev. The next day, I downloaded Express. After all of that, IS still works. The bottom line seems to be: install the product that has the most features you need; then install the extra products.


Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |