Linked Server 'access denied' | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Linked Server ‘access denied’

Hello all, this is kind of odd, I have a sql 2000 named instance. I add it as a linked server to another 2000 server, when attempt to looks at the tables from EM I get the following error ‘SQL Server does not exist or access denied’ I’ve tried several ways to connect with the same result. I’ve connected using ‘sa’ account, though scripts and the spaddlinkedserver stored proc and then ran a query. I’m out of ideas, any one ran into this before? Thanks…
Have you tried creating an alias for the server with the client network utility and specifying the network library? We use only TCP/IP for our servers, and that is usually the problem I run into.
When you’d used SP_ADDLINKEDSERVER then it worked or not?
If any errors what are they? And also how about service packs on both the servers?
Satya SKJ

Got it, The SQL Server I was attempting to connect from was using an older ver of MDAC, updated it and now all is good. Thanks…