Merge Replication Snapshot Issues | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Merge Replication Snapshot Issues

HI ,
When i run my merge replication snapshot agent i am getting ‘I/O error while writing BCP data-file’, which is normally due to disk space. I have over 73GB of space on my drive and by looking at sp_spaceused my table has reserved space of 73153192 KB(about 71GB) and data of 66632600 KB(about 65GB). Does anyone know which one of these values the merge snapshot agent will use to build up the bcp file. Also, is there other files that get created when the snapshot agent runs. I am running the snapshot file on my subscribing box and not the distribution box(there is not enough space) will this cause any issues with the BCP file being very large.
Also is there an upper limit to the size of the file that can be used in the snap shot?
The snap shot now always fails and it looks like there should be enough space to hold it, this has worked before but now has failed.
Any help is appreciated
Cheers
Gavin

Welcome to the forums.
I can sense there is a problem with disk or hardware on the server, as it clearly states I/O problem. Have you checked event viewer logs.

My drives appers to be ok , i have got other databases using the same drive space as the snapshot file and i have got no problems accessing them. Will compressing the snapshot file help and how much compression will it offer on a 65-72GB file

]]>

Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |