openquery returns less rows | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

openquery returns less rows

Hi everybody, I’m using 2 database which are oracle 9 and sql server 2000.
I want to pull down some data from oracle into sql server using openquery.
FYI, i’m using odbc to connect to oracle and the linked server on sql server
used msdasql as it’s data provider. It works altough I got less data row than i expected. For example, if i run
the query directly from the oracle I got 16 data rows, and if i run the query
trough openquery i got only 1 row. Is there anything i need to setup on the linked server. Please help…
I already try googling around for some times but got no answer. regards,
Hm… i think it’s a problem from the ODBC, because it works just fine using MSDAORA. -Fajar
Ensure the correct version of Oracle drivers are used, as this could be problem with that also.
Check this relevant link, fyi. Satya SKJ
Contributing Editor & Forums Moderator
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.