Operating system error 1450 | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Operating system error 1450

I#%92m trying to restore a very large SQL database (71 GB) to a different SQL server. I had done this several times to different servers but recently the restore has been failing. The server I am attempting to restore the database to is running Microsoft Server 2003 and Microsoft SQL Server 2000. The backup of the database is kept on a server running Microsoft Server 2003. I get the following error when trying to restore the database: BackupMedium::ReportIoError: read failure on backup device ‘\1TechSvrBackupEDMSEDMS.BAK’. Operating system error 1450(Insufficient system resources exist to complete the requested service.). Internal I/O request 0x1BB09758: Op: Read, pBuffer: 0x06AD0000, Size: 65536, Position: 72276186624, RetryCount: 10, UMS: Internal: 0x0, InternalHigh: 0x0, Offset: 0xD3FF1600, OffsetHigh: 0x10, m_buf: 0x06AD0000, m_len: 65536, m_actualBytes: 0, m_errcode: 1450, BackupFile: \1TechSvrBackupEDMSEDMS.BAK I have tried the restore several times after the backup (the full backup is run once a week) thinking that the first time I tried the restore that failed might actually be a bad file. But the restore has failed several weeks in a row (different backup files).
Our server support folks monitored both servers when I attempted to do the restore and saw no problems with either server. Any ideas?

Check, http://support.microsoft.com/default.aspx?scid=kb;en-us;826971 HTH Luis Martin
SQL-Server-Performance.com All postings are provided “AS IS” with no warranties for accuracy.
Thanks for the info but the fix for the problem doesn’t apply. The server where the backup is kept and the MS SQL 2000 Server that I am trying to restore the database to are running Windows Server 2003 OS. In any case the hotfix that the link said was the problem, has not been applied to either server. I continue to look for a solution.
I found the following link: http://www.jsiinc.com/SUBL/tip5500/rh5584.htm HTH Luis Martin
SQL-Server-Performance.com All postings are provided “AS IS” with no warranties for accuracy.
Thanks again for your response but that resolution to the problem was checked out on 7/2/04. I continue to search for the resolution to the problem.
If possible do not restore directly over network. Copy the backup file to the server first. There seem to be some general issues with copying large files though:
http://support.microsoft.com/default.aspx?scid=kb;en-us;304101 The PagedPoolSize and PoolUsageMaximum registry values probably exist for Windows 2003 as well. I wouldn’t mess with them without checking with Microsoft first.
I have resolved the problem. The error message I was getting when trying t o restore was bogus. The problem was in a path name for one of the files.
Thanks, LuisMartin and Argyle for your help. I guess I’ll always be a noobie.

Hello, I have the same problem, can you explain a little better as they deal with. Thanks already Dario