Replicated database | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Replicated database

Hi A few weeks ago i set up a transactional replication from serverA to serverB (using a push subscription from ServerA)(ServerB is on a different network). Only data can be added onto ServerA so serverB acts as a read only database. Everything worked fine and data was sychronized over every night perfectly. Then ServerB had to be rebooted for some reason and then the name of the server was not being picked up so i could not browse to it but i could ping the IP address of the server. This has been resolved and i can now browse to the server using the name, ServerB. However, since the server has been rebooted the replication does not work. I get a timeout expired error when trying to connect to ServerB to distribute the new data. I have also tried to do a whole new test replication to serverB with just a table of 5 rows but i still get the timeout expired error. Any ideas to why i am getting this error? Thanks CE
Run SELECT @@SERVERNAME and ensure the other servername is returned properly, if not use SP_DROPSERVER and SP_ADDSERVER to take on the new settings. Check LMHOSTS are upto date with all the details. Satya SKJ
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.