select count(*) error | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

select count(*) error

Dear all When I tried to count(*) the row from a table. It got the error message like ‘Attempt to fetch logical page 2900376 in database ‘abc’ belongs to object ‘0’, not to object ‘ccc’, The SQL server is terminataing this process’ I had tried to DBCC Checkdb, but no use. What can I do Thanks Kawn

This article may help.
In addition to that, execute DBCC CHECKTABLE on the second object specified in the error message. To determine the full extent of the corruption, execute DBCC CHECKDB as soon as possible. Also check the error log for other errors, which often accompany a 605 error. As listed in the BOL about error 605:
If the 605 error is not transient, the problem is severe and you must run DBCC CHECKDB with one of the repair clauses. If the error involves an index page, use the REPAIR_REBUILD clause. In addition, run hardware diagnostics and correct any problems. You might find it beneficial to perform a completely new setup on the computer, including reformatting the disk drives and reinstalling the operating system. This eliminates the possibility that a .dll or .exe program is corrupted. You can also examine your operating-system error log to see if the error occurred as the result of hardware failure.
Satya SKJ
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.