SQL 2000 SP3 – Setup hangson "Validating passwo | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

SQL 2000 SP3 – Setup hangson "Validating passwo

I have read about others who have had problems with sp3 setup on sql2k, but nobody seems to have same problem as mine.
Everithing is going fine until I type the "sa" – password. The "Validate password" windows is shown and nothing more happens. The sqlsp.log is like this (last 8 rows): 15:09:12 Begin Action ShowDialogsHlpr: 0x2000
15:09:12 Begin Action: DialogShowSdUpgrade
15:09:12 ShowDlgUpgrade returned : 1
15:09:12 Checking databases on instance ‘MSSQLSERVER’
15:09:12 Authenticate access
15:09:12 Begin SDPassword Dialog
15:09:16 End SDPassword Dialog
15:09:16 C:DOCUME~1ADMINI~1.AFVLOCALS~1TempSqlSetupBinscm.exe -Silent 1 -Action 6 -Service MSSQLSERVER I’ve checked HKEY_LOCAL_MACHINESOFTWAREMicrosoftMSSQLServerClientConnectToDSQUERY. The value is already DBNETLIB.
I’ve ceven hecked NtfsDisable8dot3NameCreation in HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControlFileSystem and it’s OK too.
The problem may be in the fact, that I have Windows 2000 AS SP4 cluster with 2 nodes. On each of them there is MSSQL 2000 Standard edition. SÃ¥ it’s not SQL-cluster, just an operation system. I tried on an activ node, on an inactive, took out one of the nodes and tested each one separately. NOTHNING! Always setup is hanging on "Validating password".
I tried sith SQL2K SP2, but it didn’t help. Tried with a new installation of sql server, but the setup just enables to add or remove server components, no reinstall. I didn’t dare to remove SQL server completely and make anew clean setup, becouse I don’t have that time and it’s complecated with that kind of clustering too.
Can anyone help me???!!
Hi there, The only thing I could find ithttp://dbforums.com/arch/71/2003/2/669921 This says to ensure that your TEMP and TMP environment variables point to a valid 8.3 directory path e.g. c: emp Cheers
Found this in a newsgroup:
SOLUTION: Validating a user error during SP3 upgrade Problem Description:
Several of you have encountered problems running the Service Pack 3 setup
where setup fails very early on while "validating a user". This problem can
occur when MDAC version 2.6 or earlier is present on the machine at the time
of upgrade. Those who received later versions of the server network library
components of MDAC through a later upgrade (MDAC 2.7 as part of Windows XP
Pro for example) will not encounter this problem. Resolution/workaround:
As Jeff Boyd noted elsewhere in the newsgroups, you can change the "DSQuery"
entry in the registry as a temporary workaround. The key
value to "DBNETLIB". We will get some type of official KB article out in the near future. For
now, I hope this helps those of you encountering this issue. Regards,
Tom Casey.
——————————— Since you already tried the DBNETLIB value what about the MDAC version. Is it 2.7 or higher? Also try with a Windows NT account rather than the sa password and make sure that SQL server authentication is set to mixed mode and not Windows NT authentication only. /Argyle
I have already MDAC 2.8 but it dosn’t help much!!!
Turn off all the other services on the system that are not required including antivirus. In our case, the antivirus software was creating problems. Gaurav
Man thrives, oddly enough, only in the presence of a challenging environment- L. Ron Hubbard

Has anyone encountered this same problem with the SQL 2K sp3 Password problem? I have made the registry hacks, disabled antivirus, installed MDAC 2.8 and I still encounter the same problem. I actually had to create both registry keys as they did not exist such as the ConnectTo key under the client tree. I’m running NT 4.0 Sp6a Any ideas from anyone?

Have you tried installing SP3a rather than sp3? 3a was supposed to have fixed some installation issues, not sure what they were off hand… Must admit that I’ve not had this problem before, not on NT, w2k or w2k3… and all installing sql 2k sp3… are you upgrading on a cluster? Cheers
I’m trying to download Sp3 not sp3a right now to see if your suggestion might work. It’s certainly worth a try.
Well, my problem was fixed by doing the following: Pay Microsoft $245. Change the SA password to something different – this ensures no users can get in. goto the SQL client network utility and enable the checkbox for shared memory connections – this was the key problem per Microsoft. If the box is cleared, you will not be able to authenticate and hence cannot continue. rerun the service pack go home happier. I hope that helps the next person. Maybe MS will post this in their KB articles.