SQL DB Entries Can't Be Queried or Seen | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

SQL DB Entries Can’t Be Queried or Seen

I have created a web/SQL Server database interface which worked perfectly until I deleted the test entries to start fresh. Now the new entries that are entered cannot be seen or queried. Can someone please help! Web Pages: asp SQL Server 2000 Internet Explorer 6.0 Background: I created a web form (asp) which is used by customers to enter requirements. Once the requirements are entered by the customer, the information is saved to a SQL server 2000 database. The customers can click on "Query Requirements" link to get the status which will be input later by the requirements manager. After running test, I deleted all the test entries which started at # 2005001. Now I can’t see any new ones that I enter. Initially I deleted all but one of the requirements, and that was the only requirement that I was able to see. Following that, I deleted the last requirement to see if I needed to delete all of the old req and start fresh. Now I can see absolutely nothing. I was able to see the test requirements before I deleted them (approx 19) When I enter a new requirement now, the information is saved in the database and I see the new requirements there – I just can’t query it.
Start by looking at the queries coming in from the webserver. Initial guess is that the data isn’t meeting the required criteria in the JOIN or WHERE clause. This would explain why you can query it from Query Analyzer and see the data, but not from your asp app. The data doesn’t meet the SARGS criteria, or you’ve created ‘orphaned’ data by deleteing your test data.
When you say the data is saved in the database, but you can’t query it … How do you know it is being saved into the database if you can’t see it? Is it possible that there are two identical table names with different owners and you are inserted to one version of the table, and trying to select from a differently owned table. Just a thought. Can you give us the create table script, the script you are using for insert, and the script you are using to query?
Thank you all for your insight. I checked the join statement and it appeared that I deleted a link to one of my relational tables. I added the relational table again and it worked. Thank you…..