SQL Server 2005 Cluster | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

SQL Server 2005 Cluster

I have SQL Server 2005 cluster server, every time open SQL Server management studio, there will generate error on event view Event filter with query "select * from __InstanceModificationEvent within 10 where TargetInstance isa ‘Win32_Service’" could not be (re)activated in namespace "//./root/Microsoft/SqlServer/ComputerManagement" because of error 0x80041010 Does any one know how to fix it?
Can you connect with SSMS from a workstation?
Have you tried to connect from another client’s machine?
Check workstation event viewer for any information on any failed services. Satya SKJ
Contributing Editor & Forums Moderator
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
We have two cluster SQL server 2005 both have same problem, I have tried different client machine include server itself all have same errro, but the other non-cluster sql server 2005 do not have this error, my client PC event view do not have any error. Thank you for the help
This looks like an WMI issue. Is the WMI servie running? If it’s running but still not working the WMI repository could be corrupt. Help on how to troubleshoot here:http://www.microsoft.com/technet/scriptcenter/topics/help/wmi.mspx
Thank you for the response. Could be this is bug from SQL server 2005, since this is cluster server \. which means \localhost.. but here should be \virtualservername..
because SQL Server management studio work with WMI, the error say invalid class which include in SQL Server 2005 design code and I can’t change any, is any one know some place I can change(either some XML file or regedit) to add virtual server name to replace local host? Thanks
I don’t quite get your last post, but; When you open SSMS on a client workstation you should have no problem. When you connect to the cluster you should specify the virtual sql server name that you specified when you installed the instance of SQL Server on the cluster. \. or ‘localhost’ should not be part of the connection either locally or remotely with SSMS.
The error is invalid class from "//./root/Microsoft/SqlServer/ComputerManagement", this only happen on cluster server, I guess it may because //localhost/ cause invalid class, but my SQL Server management studio works all fine except so many this error on event view, and I like to resolve it. Thanks for any help
Ah, so SSMS is not generating this error – is someone trying to use compmgmt.msc?
I think this is from SSMS, whenever you open SSMS, there will be error, but SSMS works fine with no problem.