Sql Server Authentication | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Sql Server Authentication

If we have a client that has a local ODBC connection with a valid generic login/password for the application, and yet the person whos machine its running on is a sql administrator, in what order does SQL assign security..? I mean even tho the client has rights, it appears to be using the current users name rather than the ODBC application’s name.. Will it try windows authentication first, or SQL server authentication first, and if so does done take priority over the other…??
Thanks,
David
-David Roesch
San Diego, Ca
SQL Server will use Windows Authentication (default) or SQL Authentication if configured as such and not both. There is no priority associated with either of the authentication mechanisms as far as I know. What is the Authentication setting on the SQL Server? If it is "Windows Authentication" then it will use the Windows account of the currently logged on user (or the Admin’s if he did not log out!) and reject any login/password presented to it. If it is "SQL Server Authentication" then it will use the valid login/password value pair you present it. In this case it will use the credentials presented by the ODBC application. Nathan H.O.
Moderator
SQL-Server-Performance.com
Hi, thanks for responding.. We are using Mixed mode authentication. The reason why I asked this question is while testing a application we were making mods to the ODBC setting for the app on this administrators machine. So therefore it should have logged on using the ODBC information, yet it did not. I returned saying it could not authenticate the WINDOWS user, and not the ODBC user. So I was quite surprised by that. -David Roesch
San Diego, Ca
Do you specify sql login and password in your connection string as well? It’s not enough to just specify the login and password in the ODBC settings and then only refer to the DSN name in the connection string. If you do that windows authentication will be used. If you do specify login and password please post the connections string with the password removed. /Argyle
]]>