Unable to remove Subscriptions | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Unable to remove Subscriptions

I have a problem with a subscription. Last week, we lost a database due to some hardware issues. We restored the database from tape, and now I need to get the replication going again. The subscriptions are still in existence, but the publications are not. I#%92m unable to remove the subscriptions, and I#%92m unable to create new publications. How do I remove the subscriptions without any publications? Any help would be great. Thanks Pat
Check this link http://www.databasejournal.com/features/mssql/article.php/1459051] _________
Satya SKJ

Satya SKJ, thank you for the information. Sad to say, it hasn’t worked. The option to drop the subscriptions returns an error stating that it cannot find the publications table. All the databases that are being replicated have this table. Some do not have records though. I went ahead with the rest of the instructions, but it would not allow me to change the dboption of published to false. Is there another way to remove the replication? I’m running SQL Server 7.0 with all the latest service packs.

Have you tried to remove replication entirely, then readd it? Or maybe this is not an option for you. ——————
Brad M. McGehee
True the one and only. _________
Satya SKJ