Uninstalling SQL Server Cluster | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Uninstalling SQL Server Cluster

I’m documenting my experience/nightmare with EE SQL Server 2005 SP2 Cluster uninstall. Maybe a few links mentioned below could be of help..
Upon installing new 64bit iSCSI SQL Server 2005 EE Cluster, vendor suggested ( wasn’t documented in their readme file) I should change the NTFS block size on the partition to 64K. The following article helped with understanding the defaults:
http://technet.microsoft.com/en-us/library/bb457112.aspx
Steps involved uninstalling cluster:
1. Snapshot the volumes. (Data/Backup/Log)
2. Uninstall SQL Server including Integration Services, SQL VSS Writer, SQL Browser, Setup files
3. Delete disk resources from the nodes.
4. Restart nodes.
Within Disk Management on these nodes, made changes to Logical Volumes by right clicking on each-> Select Format-> Change the Allocation Unit Size to 64K and was ready to install SQL Cluster. Added the disks back into their respective Resource groups, performed Manual fail over, worked fine.
Started the SQL Server install process, got stalled half way. From various posts that I read suggested the install takes a bit longer. My wait time exceed over 30 minutes and still the progress bar showed no signs of progress. So I decided ( BIG MISTAKE!!!) to cancel the install which triggered the fun part ..
Apparently it appeared that the "uninstall" worked and was ready to run the setup after reboot. Kept on getting the following error:
"The Setup has encountered an unexpected error in datastore…". Found the following link which corrected the issue:
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=354408&SiteID=1
Once SQL Server was installed successfully:
1. Applied SP2 on each nodes being an ACTIVEACTIVE cluster
2. Mounted snapshot volumes.
3. Within iSCSI initiator, "loaded" these targets from the "Target" tab by clicking refresh. Logged the volumes into the cluster nodes
4. Within Disk Management assigned letter to this new volume by right clicking on it and selecting "Change drive letters and paths".
5. Stopped SQL Services from with each node using Cluster Administrator by getting them offline.
6. Renamed existing "Microsoft SQL Server" folder from the shared resources. Copied the folders from the newly loaded snapshot volumes into the respective drives (Data/Log/Backup).
7. Restarted SQL Services.
8. Logged in SSMS, confirmed all the user databases are listed, ran CHECKDB on each.
9. Moved resources between the Cluster groups successfully.
Hope no one has to go thru this but if u are facing the incomplete uninstall issues, this might help resolve the issues related.
Thanks
Thanks for sharing your experiences…

Why not you writeup a blog here based on this experience?
If not let me know I can do that by giving credit to you…

I might not have access to create new blogs. So if someone can post it please..
Thanks

Ok here you go – http://sql-server-performance.com/Community/blogs/satya/archive/2008/02/03/140534.aspx [:)]

]]>

Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |