Unknown token error | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Unknown token error

Hello Lately, after an upgrade so MDAC 2.6SP2, when running certain queries from query analzyer directly on the db server (sql server 2000 sp1), I’ve been getting "unknown token received" errors. When I run this from query analyzer on my local pc (MDAC 2.7), these errors do not occur. I can upgrade the db server to sql server 2000 sp2, but that’s as far as the main application that runs against this db will allow me to go. Does anyone know if there are known problems running MDAC2.6SP2 against sql server 2000 sp1 or if it is bad idea to have MDAC2.6SP2 installed on a db server running sql server 2000 sp1?

Well, MDAC26 SP2 has same components like SQL 2000 SP2, so I gess you should install SP2 on SQL 2k.
BTW: Why application will no run with SQL server SP2?
Luis Martin …Thus mathematics may be defined as the subject in which we never know what we are talking about, nor whether what we are saying is true.
Bertrand Russell

make sure that you do not mix MDAC versions on client/server, and also if you downgrade you may get somefiles downgrading correctly while others do not. All should be at the same level… use something like the mdac checker from MS to make sure that all DLLs are at the correct MDAC level Cheers
There are a couple of articles on Microsoft Support site…. http://support.microsoft.com/search…d"&QuerySource=gsfxSearch_Query&srchExtraQry= Gaurav
Man thrives, oddly enough, only in the presence of a challenging environment- L. Ron Hubbard

Thanks for the input. I’ve seen those docs on the MS website — I guess I’m just looking for something more concrete that tells me that the problem is MDAC2.6sp2 running against sql 2000 sp1 — but I haven’t found it yet. The MDAC versions are the same on client/server. Interestingly enough, if I run the query from query analyzer (MDAC 2.7) it works — server is on MDAC 2.6sp2. The problem is that I run the statement that gets the "unknown token" error directly on the server from query analyzer – so an mdac client/server mismatch can’t be the problem. I think that there must be some components of MDAC 2.6sp2 and sql server 2ksp1 that aren’t playing well together – I’m guessing that sql server 2ksp2 will resolve the problem, but I don’t know for sure. Unfortunately, guessing isn’t good enough to get it implemented. I may have to get a hold of MS on this issue. If so, I’ll let you know what I find out.
and you have checked the versions of dlls using the mdac component checker from MS? http://www.microsoft.com/downloads/…F6-4A21-4B43-BF53-14332EF092C9&displaylang=en Cheers