Web cluster > SQL Server connection problem | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive

Web cluster > SQL Server connection problem

Hi there,
At the risk of sounding like a total newbie I have what I think is a simple setup problem: Config:
2 x web servers (W2K Adv Svr) in NLB configuration
1 x SQL Server 2000 (W2K) IP address 192.168.0.130 is the cluster address
Each web server has their own physical IP address (192.168.0.131, 132) Problem:
When testing db connectivity on each of the servers I found only one can establish a connection to SQL Server at any one time. I have confirmed each server can establish a connection independently. Running NETSTAT on the SQL box shows a connection on port 1433 for IP 192.168.0.130. Everything else works perfectly. Any assistance would be appreciated.
Thanks!
Hi ya, How have you set up the web nlb? is it multicase or unicast? If it is unicast then do you have multiple network cards? from the SQL perspective connections should appear to come from the individual servers, the fact that you have the nlb ip address showing is the key to your problem I think Cheers
Twan
]]>

Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |