xp_enumgroups | SQL Server Performance Forums

SQL Server Performance Forum – Threads Archive


I was hoping some people could verify something for me. I have SQL 2000 SP3 setup in a DOMAIN. When I run the following command: EXEC master..xp_enumgroups ” It returns a list of my domain groups. However if my SQL box is setup in a WORKGROUP and I run the same command I get: Stored function ‘xp_enumgroups’ in the library ‘xplog70.dll’ generated an access violation. SQL Server is terminating process 52. Firstly in the DOMAIN scenario, as I am not passing in the name of the domain why does it not return a list of local groups as BOL suggests? Secondly why does the WORKGROUP scenario crash out? This is code taken from a supplier and is therefore difficult to change! cheers

According to Microsoft, you should have the "latest" SP … but I am not too sure about the validity of that suggestion. Maybe this article will give you some headway: http://support.microsoft.com/kb/294338/EN-US/

Thanks Tahsin It says that the problem was first fixed in SP1 and we’re running SP3. At least our suppliers have acknowledged the bug and are providing a patch. Thanks anyway.
I believe that is a default behaviour on workgroup as the behaviour is :If a large parameter is passed to the xp_enumgroups stored procedure, an Access Violation is generated, and the connection terminates. Try listing the groups from NT on the workgroup. Satya SKJ
Contributing Editor & Forums Moderator
This posting is provided “AS IS” with no rights for the sake of knowledge sharing.