SQL Server Performance

Books Online not working in SS 2008 R2 Dev

Discussion in 'SQL Server 2008 General Developer Questions' started by HankWalters, Mar 18, 2011.

  1. HankWalters New Member

    Hi Folks,
    I am running Windows 7 and had an install of shared components that came from a SQL Server 2008 R2 Standard Edition that was working just fine. Then I did an install from SQL Server 2008 R2 Developer's Edition and created a db instance. From that point on I get a message box with the following error whenever I try to search local help from SSMS:

    Exception from HRESULT: 0x8004032D

    When I try to bring up Books Online from the menu I get this error:

    Microsoft Document Explorer cannot be shown because thespecified help collection ‘ms-help://MS.SQLCC.v10 is invalid.

    I also get the same error when I try to bring up Tutorials from the menu.

    I have tried: repairing BoL, downloading and reinstalling BoL, uninstalling and reinstalling shared components (SSMS, BIDS, etc.), and removing/uninstalling all of SQL Server (shared components, the db instance, etc.) and reinstalling. It seems to me that one of the steps should have fixed the problem but no luck.

    I have done some searches and have not found anything that helps (at least not anything that I have not already tried). Has anybody seen this before? Any ideas that I can try to get local help working?

    Thanks!
    Hank
  2. satya Moderator

    What version of IE you are using?
    I had similar problem in the past when I tested IE9 and uninstalled, reinstalled IE8 all the BOL contents gone AWOL. The solution is to uninstall any versions of books online you may have on that machine and reinstall afresh (with a reboot).
  3. HankWalters New Member

    Thanks for the reply, I've been out of the office for a few days. I generally use Firefox and the IE that I have is what came with Win7 by default. It is 8.0.7600. I have tried uninstalling/reinstalling BoL but maybe I failed to boot in between. If it is that easy, I'll be happy. I'll let you know.
    Thanks again,
    Hank
  4. HankWalters New Member

    No luck yet. I thought I had tried this already.
    Since I posted, I have discovered that the problem is bigger than just BoL. None of the help systems work for SS, Office 2010 apps, Visual Studio, or MS Access 2007. I am guessing that the issues are interrelated. So I am looking into that now.
    Thanks again,
    HW
  5. satya Moderator

    I guess the help contents by MS products will use IE related program, I guess it will be ideal if you can uninstall and reinstall IE7 or 8 in thsi case to see if that resolves the problem.

Share This Page