SQL Server Performance

deploying a cube fails...

Discussion in 'SQL Server 2005 Analysis Services' started by samsqlserver, May 8, 2008.

  1. samsqlserver New Member

    Hello people,
    When i am trying to deploy a cube it fails with the following error:
    the user "servernameuser" do not have permission to create a new object in "servername" or the object do not exist.
    Can any body help me out.
    I tried doing this:
    connect to analysis server, go to properties --> security and tried to add a user but that too failed with the following error:
    servernameuser do not have permissions to alter the "server"
    on all the occasions i tried to login with the administrator account.
    Any ideas of how to solve this...
  2. satya Moderator

    What is the authenication mode used to connect that AS instance?
    You cannot use SQL Server authentication to connect to Analysis Services. The page http://msdn2.microsoft.com/en-us/library/ms144288.aspx says that "SQL Server 2005 Analysis Services supports only Windows Authentication."
    Moreover the whole action fails due to lack of permissions, to add them:
    1. Login as local administrator and using Sql Server Management Studio connect to Analysis Services Instance.
    2. Right Click on the server in "object explorer" and select Properties.
    3. Go to Security tab (select a page pane)
    4. Click Add and add "mydomaindevelopers" into the "Server" role for Analysis Services.
  3. samsqlserver New Member

    Firstly i thank you satya...
    ok. i obviously used windows login itself and also as a local administrator infact my login is the only login into the machine and it's the admin login.
    is there anything i can tell u more to resolve this.
  4. satya Moderator

    Can you check whether SSAS service is started or not?
  5. samsqlserver New Member

    the problem was solved.. .i dont know how it was resolved but i all i did was restarted the SSAS service, refreshed the project that i created and the like...
    thakx satya for you ur advice,....
  6. drwilliam New Member

    Besides the SSAS service must be started, in the network structure that is implement active directory services, your SSAS SQL server must be joined the domain, otherwise, only local nodes can be functioned.

Share This Page