SQL Server Performance

Dimensions Not Working After Making Changes

Discussion in 'Analysis Services/Data Warehousing' started by RDixon, Nov 24, 2004.

  1. RDixon New Member

    Just to let you know, I'm fairly new with SQL Analysis Server and developing CUBES.

    I've created a cube with several Star Dimensions, based on the Fact Table. The Fact Table is one large De-Normalized tabled, developed by a job that is run on nightly basis. This job updates appropiate information so I can access various dimension elements based on FACT Table values.

    Now, the cube functioned without any errors before I started modifying the views and calculations on the SQL Server to ensure data integrity. Now, when I run the cube, I get the error below.

    [A member with key 'Between 41 and 79' was found in the fact table but was not found in the level 'Iowa Rank' of the dimension 'IOWA Rank Elementary'.; Time:11/24/2004 10:08:03 AM]

    'Between 41 and 79' is a new addition to the dimension table, updated via an UPDATE function. Further, this error is happening for other dimensions that I have not modified, as well, such as a Homeroom dimension which does not caluculate. (By the way, all my calculation, so far, are in the SQL Views, not the cube, except for AVERAGES.)

    The funny thing about this error, is that this value is in the fact table, and when viewing the dimension in edit mode, it is on that list as well. It's just not showing in the edit mode of the CUBE when I run the Processing and view the DATA.

    Any suggestions?

    Thank you,
    Robin
  2. Raulie New Member

    What Storage mode are you using (MOLAP, HOLAP, ROLAP) and what type of cube processing are you performing, full, incremental etc?
  3. RDixon New Member

    I am using HOLAP storage mode, and FULL processing.

    Robin
  4. Raulie New Member

Share This Page