SQL Server Performance

DTS Error - What does this mean?

Discussion in 'SQL Server DTS-Related Questions' started by picses, Aug 25, 2004.

  1. picses New Member

    Hi Group,I get the following error when I run my DTS Package.
    The number of failing rows exceeds the maximum specified.
    TransformCopy 'DTSTransformation_16' conversion error: Destination does not allow NULL on column pair (source column 'column name'(DBTYPE_WSTR),destination column 'column name'(DBTYPE_STR)).

    I've checked the source file and it looks OK.

    Kind Regards
  2. sundeip New Member

    Check Your Target table column , Wether That column allow NULL or Not.

    Sandy

    (DB Developer)
  3. satya Moderator

    If any data for this column will be exported with NULL values, then define a DEFAULT value in order to overcome the above error.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  4. FrankKalis Moderator

  5. derrickleggett New Member

    If your column doesn't allow NULL, it will just skip the column. If you go to design view on the DTS package, then right-click in the background and go to properties, you will see a maximum error count and a few other options. You can write the errors to another table so you can inspect them. You can also set the maximum count extremely high so you can import everything except the errors.

    MeanOldDBA
    derrickleggett@hotmail.com

    When life gives you a lemon, fire the DBA.
  6. picses New Member

    Hi All,<br />I've worked it out!! It was the data source.<br />For your reference in case you have a similar issue, I tested the Transformation that was causing the error and inspected the temporary text file that gets created.<br /><br />The text file generated a fixed string length(4 characters) for **null** values in this columns, but for some records, it generated a single character. i.e instead of " ", I had "". <br />On looking at the source data for these records, they had numeric data when the data field should hold text. On deleting the numeric data out of these fields (which shouldn't be there in the first place) the import worked!!<br /><br />Those temporary text files are great for debugging!! - If you know what to look for <img src='/community/emoticons/emotion-1.gif' alt=':)' />)<br /><br />Regards<br />
  7. helmza New Member

    Hi,
    Where do the temporary text files get created?

    Thanks,
    Hella
  8. satya Moderator

Share This Page