SQL Server Performance

Error while adding article

Discussion in 'SQL Server 2005 Replication' started by ramkumar.mu, Aug 26, 2009.

  1. ramkumar.mu New Member

    We have a transaction replication setup which has 4 publications. In one of the publications (which already has 6 articles), we are trying to add an table and it is throwing the below message...· The process could not bulk copy into table '"dbo"."NodeAdCache"'. (Source: MSSQL_REPL, Error number: MSSQL_REPL20037)
    · Cannot bulk load because the file "E:MSSQLMSSQL.1MSSQLReplDatauncNAMADMD38SQL1_CIMSAGGREGATE_CIMSAGGREGATE20090825164026NodeAdCache_4.bcp" could not be opened. Operating system error code 3(The system cannot find the path specified.).
    Get help: http://help/4861

    The person who is adding the article has SYSDBA privileges on the server.
    We tried...
    1. Dropping the folder NAMADMD38SQL1_CIMSAGGREGATE_CIMSAGGREGATE
    2. Dropping the table (that is to be added as an article) and recreated it
    But nothing worked.
    Any help?
  2. MohammedU New Member

    Make sure folder exists and SQL Agent has the rights....
    and also try modifying the snapshot location...
  3. ramkumar.mu New Member

    Mohammed,
    Yes the folder exists and SQL Agent has permissions (there are 3 more publications in the system. even the same publication has 2 existing articles and working fine)
    We tried changing the folder, but it didnt work.
    Any other options?

Share This Page