SQL Server Performance

Expression Error - after deployment of reports

Discussion in 'SQL Server Reporting Services' started by mkmathi, Dec 22, 2005.

  1. mkmathi New Member

    Hi,

    I am using .Net dll to have common function. I#%92m querying database from dll functions. That functions will return some values to Report Expressions.
    I'm able to get result of the dll functions in preview & Print layout.

    My problem is after deploying the report I#%92m getting #error in all textboxes wherever I#%92m
    Calling dll functions that particularly involved in querying database.
    Rest of the function in the same dll simply using for some calculations are working.

    Thanks & Regards
    Mathi [xx(]


    Thanks & Regards
    Mathivanan K
    Great work may have to pass through these stages - ridicule, opposition, and then acceptance. Each man who thinks ahead of his time will probably be greatly misunderstood.- vivekananda

  2. smy New Member

    Hi,
    My response may be too late to help you..but hopefully those who face this problem now, can use this as reference to help up..
    For .dll file used together with Reporting Services, you need to set the following..

    C:program FilesMicrosoft SQL Server80ToolsReport Designer
    spreviewpolicy.config

    <CodeGroup
    class="FirstMatchCodeGroup"
    version="1"
    PermissionSetName="Execution"
    Description="This code group grants MyComputer code Execution permission. ">

    Change the PermissionSetName="Execution" to PermissionSetName="FullTrust"


    Do it to
    C:program FilesMicrosoft SQL ServerMSSQLReporting ServicesReportServer
    ssrvpolicy.config

    and the #error fields will be gone.

    But be cautious, amend it with care. else, it will affect the whole reporting services program.

    Advice here is: Do backup a copy of the config files before amending the above.
  3. smy New Member

    fyi: the reports will render #error are due insufficient rights for the codes to be executed on the machine

Share This Page