SQL Server Performance

Please Help! urgent

Discussion in 'General Developer Questions' started by rem090rem, Mar 23, 2007.

  1. rem090rem New Member

    Hi All,

    Please help me I don't know what went wrong but when I try to redesign the tables in my sql database it will open to a new window without any information of the table as in empty no fields no everything...

    Please help how to configure this...

    Thanks.

    rem090rem
  2. Luis Martin Moderator

    What tool are you using?


    Luis Martin
    Moderator
    SQL-Server-Performance.com

    All in Love is Fair
    Stevie Wonder


    All postings are provided “AS IS” with no warranties for accuracy.



  3. rem090rem New Member

    MS SQL Server 7.0...

    when i open it to enterprise manager it will shows you the list of database and list of tables but when you try to redesign the tables it give nothing even a single fields..

    Please help me this is a urgent matters...

    thanks.
    rem
  4. Adriaan New Member

    You are trying to access an instance from SQL 7.0, but are you using Enterprise Manager? And from which version? You can access SQL 7.0 from the SQL 2000 EM - not sure if the SQL 2005 tools support SQL 7.0 - just as SQL 2000 doesn't support SQL 6.5.

    You can always use the SQL 2000 Query Analyzer ...
  5. rem090rem New Member

    from the same version...there's a EM in the SQL Server 7.0, really we can use it but we don't have it what we are having right now is this kind of version, and we need to configure it out with this kind of SQL. why it doesn't show anything from EM I mean the fields, rows, columns what could be the problem? and how you guys edit or redesign your tables from SQL Server 7.0?

    thanks!
  6. Adriaan New Member

    Try the SQL 7.0 Query Analyzer. If you already have SQL 2000 installed, you can't have the SQL 7.0 QA installed on the same computer.
  7. Akthar New Member

    Use SQL query analyzer with the
    Alter Table command
    See books online installed on your SQL server Machine for the syntax.

    Hope this helps, Post your table structure for the correct syntax


    AKTHAR
  8. rem090rem New Member

    guys, i'm having this kind of error...

    every time I command the **show** for tables and database it says that invalid commands...

    Simple commands can't execute why?

    thanks!
    rem090rem
  9. Akthar New Member

    tell us what version of SQL Server you are using for the DATABASE and what SQL ENTERPRISE MANAGER you are using SQL 2000 or SQL 7?




    AKTHAR
  10. rem090rem New Member

    im using MS sql server 7.0 also in EM...

    rem090rem
  11. rem090rem New Member

    I am using MS sql server 7.0 all in all (as in all).

    thanks
    rem090rem
  12. Akthar New Member

    Have you tried re-installaing EM

    AKTHAR
  13. rem090rem New Member

    no...I haven't try anything to solve it.

    actually the server is located from other country, so we haven't do anything I am still trying to configure why is that because this is the first time it happened to me.

    thanks Akthar

    rem090rem
  14. Adriaan New Member

    Have you tried removing and re-registering the server in Enterprise Manager?

    Could it be that the remote server has been upgraded to SQL 2000 or 2005? And if you are connecting with Windows authentication, double-check with the network admin on the other side, and/or try connecting with the sa login.
  15. rem090rem New Member

    ok i will...

    I don't think it was upgraded to other versions before but actually we are planning right after we configure this...

    The system admin told me that I am in a SA acct., I'm not using the SA for SQL to log-in...

    anyway how to check or add myself to the list of SA in SQL Server 7.0?

    thanks to all of you guys for helping me out...


    rem090rem
  16. Adriaan New Member

    You can always use "sa" as the login name with under SQL authentication, provided that you know the password for the "sa" account.
  17. rem090rem New Member

    well im not using SA acct...anyways I will ask our system administrator for that and I will post it what will happen...thanks

    by the way how to create another AS account?

    and I also have other problem...Our Server which run Ms SQL Server 7.0 as our database is deleting some data, what could be the reason?!

    do you think it is because I'm editing our website while our website is on-line?

    or any suggestions?! I've already seen the event viewer from OS but the System administrator and a Web developer told that it is not connected to the issue which the deleting of data in our db...

    so guys what could be the problem?!

    thanks.

    rem090rem

  18. Akthar New Member

    hi,
    I think you must use profiler with TSQL commands as counter to see who and at what interval records are being deleted


    AKTHAR
  19. rem090rem New Member


    **********Akthar

    T-SQL?! hehhehe don't know how to use tSQL...

    do you have any other way?!

    if ever i will use TSQL what command should I use?!

    is it almost the same of the natural SQL command?!

    thanks

    rem090rem
  20. Akthar New Member

    no no need to know tSQL.

    Infact what i meant is you can use PROFILER tool to log all actions on SQL Server... You CAN USE THIS TOOL TO SEE WHY YOUR DATA ARE BEING DELETED

    AKTHAR
  21. MohammedU New Member

  22. rem090rem New Member

    Akthar and MohammedU thanks

    I'll post again if there's a changes...

    thank you guys

    rem090rem

Share This Page