SQL Server Performance

Slow virtual cube processing

Discussion in 'Analysis Services/Data Warehousing' started by gus, Nov 28, 2006.

  1. gus New Member

    I have a cube with two partitions ( over time ).
    One with recent data and one with older.

    Processing the two partitions takes 1 second for one and 4 seconds for the other.
    That's ok and pretty fast.

    But when the virtual cube is processed it takes 1 minute 3 seconds.

    Those are small cubes with small fact tables. 9000 rows tops.

    As I understand the vitual cube doesn't really exist, it's just pointers or indexes over the real data.

    I don't undestand why the virtual cube processing takes so much time.

    Where do I have to start looking for this slow processing ?
    Where the problens might be ?

    Please give me some directions to as where to start looking.

    Thanks.
  2. ranjitjain New Member

    Hi,
    You can give this a try:

    increase the values of Read-Ahead Buffer and Process
    Buffer size in Processing Settings tab.
  3. gus New Member

    I've tried but the processing times are the same.

    Anything else you can think of ?
  4. gus New Member

    The strage thing is, when I process only one partition ( with the MMC Analysis Manager ) the processing is fast and there is no "virtual cube processing".

    But when I process the whole cube, even with refresh data, after processing the two partitions, there is a last vitual cube processing step.

    I don't undestand this very well.

    how come when I process the two partition separately, it's fast and there is no virtual cube processing ( the thing that slows down the whole processing ) ?
  5. ranjitjain New Member

    Hi,
    In theory, virtual cubes processes in seconds, so if you process only the vcube on its own, then how much time does it take and
    btw which service pack is installed on AS server?

  6. gus New Member

    This time :

    Start time: 12:59:30 PM End time: 1:00:33 PM Duration: 0:01:03

    a LOT of time.

    I don't know what I have wrong.
    The virtual cube is built upon 4 cubes. with 8 shared dimension and 1 private dimension.

    there should be 300 o 400 measures TOPS.

    Of course SP4 ( 8.00.2039 )
  7. gus New Member

    I've copied the cube locally and I'm removing things so as to discover at which point it speed up processing.

    Until now I've removed everything but two cubes inside the virtual and only one dimension.

    It still takes 1 minute to process.

    I'll start to remove measures now to see what happens.
  8. gus New Member

    Apparently it has to do with the number of measures.

    I left just one dimension and one cube and a few measures and the processing is fast.

    I added 100 measures and the virtual cube processing took 6 seconds.
    And as I add more measure to the virtual cube, the processing time gets slower and slower.

    Is this normal ?

Share This Page