SQL Server Performance

sql 2005 litespeed error while taking backup of t-log and fulldatabase

Discussion in 'Third Party Tools' started by harini.hanu, May 6, 2009.

  1. harini.hanu New Member

    HI all while taking the full and t-log backup of database using litespeed i got the error
    XML RETURNED FROM DATABASE ENGINE WAS INVALID. I FOUND THE FOLLOWING SOLUTION FROM GOOGLE.
    1)Add the @maxtransfersize parameter to the backup and reducing the size to 500Kb (512000), then perform the backup again.

    2)The other parameter that has been used in conjunction with the MaxTransferSize parameter has been the Threads parameter. By default this is set to 3. Add the parameter @threads to the backup script and reduce it to 1. The best results have been found using 2-3 on a multi-processor environment. This parameter is available within the LiteSpeed Backup options from the Enterprise Console.

    3) SQL Server's MemToLeave area becoming fragmented so that there is insufficient contiguous space to allocate the buffers required for the backups. Microsoft's suggestion to resolving the issue is to use the start-up parameter '-g' with SQL Server. The '-g' parameter can be set in Enterprise Manager by right-clicking on the server, selecting 'Properties' and clicking on the Start-Up parameters button at the bottom of the properties window. The default -g setting is 128Mb. It is recommended that -g256 is used, if this does not resolve the issue increase the value to -g512. Changing these settings does require SQL Server to be restarted for the changes to take affect and in production environments this is not always possible.

    4) NT Fibers work best when the server has multiple CPUs and a relatively low user to CPU ratio. For example, on an Enterprise installation with 32 CPUs and 250 users, you may see a noticeable performance boost with fibers. But when you have eight CPUs and 5000 users, you may see performance decrease with fibers. LightWeight Pooling is an advanced option. Sp_configure system stored procedure allows verification as well as a change to system settings in SQL Server 2000 and 2005. Note, for a change to this setting to take effect requires a restart SQL Server services

    To figure out the contiguous transfer size set up currently run the command XP_MEMORY_SIZE from within Query Analyzer. This should change if the -g setting is implemented.
    CAN some one throw more light on this topic
    Thanks
  2. MohammedU New Member

    I had a memtoleave memory issue more than a year back on one of our server when I used LiteSpeed. After upgrading to the latest version we never had a issue.
    I would adivse you to check with scheduling of backup jobs and make sure all tlog and full/diff backups spread and make sure there are not more than 2 backup jobs running at the same time.
    I opned the case with MS and LS...both pointing at each other...[:)]
  3. satya Moderator

    Did you report/check with Quest in this case for any leads on the behaviour?
    I believe it is better to check with vendor directly, I believe Quest is best to resolve such issues when reported from community.
    (moved from Getting started forum section).
  4. harini.hanu New Member

    thanks for all suggestions. i restarted the server and problem got resolved and also opened the case with quest.

Share This Page