SQL Server Performance

SQL Server jobs enable problem

Discussion in 'General DBA Questions' started by rajeev_id, Jul 14, 2005.

  1. rajeev_id New Member

    I am using SQL Server 7.0 with sp3.
    One strange thing is happening when I see one of the job which is showing as enable as "Yes", But when I right click and go to the properties and check schedule part their it is showing as enable as “No” (enable is uncheck). When I click that check box for enable it, it saves properly but when again I see it is uncheck.

    Is their any sql bug?


    Rajeev Kumar Srivastava
    --ALWAYS BE POSITIVE!--
  2. satya Moderator

    That is another flaky feature of Enterprise Manager, that too in version 7.
    For correct information go by SP_HELP_JOB statement.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  3. rajeev_id New Member

    Hi Satya,

    Through SP_HELP_JOB sp I can see it is enabled=0
    I think it is disable.

    So how to correct it, Is it not possible to do it from Enterprise Manager at least for next time after correcting once through sql sp's, because application user should not have problem for next time.

    Thanks


    Rajeev Kumar Srivastava
    --ALWAYS BE POSITIVE!--
  4. satya Moderator

    Check under the result set of Job Schedules Enabled - whether the schedule is active (1) or not (0).
    It is not possible I think as previously I've tried many times to get rid of this mis-interpretation.

    BTW why do you allow application user to go thru EM jobs, if you want to show them result of jobs then use TSQL code to display the results with your own features.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.

Share This Page