SQL Server Performance

Starting named instance via command prompt

Discussion in 'SQL Server 2005 General DBA Questions' started by ramkumar.mu, Mar 22, 2009.

  1. ramkumar.mu New Member

    I have Developer Edition and for testing DB Mirroring i installed two instances (. and ./TEST) in my workstation.
    Since DEV-Ed needs enable T1400 at startup, i decided to run these commands in my sql server folder...
    for default instance => sqlservr -T1400
    for named instance => sqlservr -S Test -T1400
    my default instance started without problems but while starting named instance, i am getting an error
    "Your SQL Server installation is either corrupt or has been tampered with (...). Please uninstall the re-run setup to correct this problem"
    Can anyone help me with this error?
  2. SmartDBA New Member

    Did you start the named instance of SQL Server from the command prompt by entering the below command. sqlservr.exe -c -s {instancename}
  3. ramkumar.mu New Member

    Tried this one too.. But didnt work. [:(]
  4. satya Moderator

    From where you tried this command?
    You could try: net stop MSSQL$ instancename
    BOL refers that:
    You must switch to the appropriate directory (for the instance of SQL Server named instance you want to start) in the command window before starting sqlservr.exe. For example, if Instance1 uses mssql$Instance1 to store its binaries, you must be in the mssql$Instance1inn directory to start sqlservr.exe.
  5. ramkumar.mu New Member

    I guess the background would be a crucial point here...
    I was trying to do DB Mirroring on my workstation and had two instances for that. Since these instances were of Developer Edition, I had to enable T1400 flag for activating mirroring support. So when i was trying to start instances with flag T1400, i am facing errors.
    But yesterday i tried starting the instance from the directory name and it was working. Now i have to try the same with T1400 flag
    Thanks Satya, SmartDBA
  6. ramkumar.mu New Member

    Thanks All... Its working now. The problem was - i was trying to invoke the named instance from default instance.

Share This Page