SQL Server Performance

Uninstall From a cluster

Discussion in 'SQL Server 2005 General DBA Questions' started by satya.sqldba, Dec 13, 2007.

  1. satya.sqldba New Member

    I have tried to uninstall an instance from the cluster and when I do it from the add/remove programs it throws in the following errors:
    The setup has encountered an unexpected error while Completing Commit. The error is: Fatal error during installation.
    Failed to set registry settings for server network libraries. The action is SetShilohRoot. The error is 2 (The system cannot find the file specified.
    The uninstall has failed all the 3 times I have tried with the same message. Any idea why its going wrong?
    Thanks
    Satya
  2. satya Moderator

    Check updated BOL for "How to: Manually Uninstall a SQL Server 2005 Failover Cluster" and also various other services you may need to manually uninstalled as well as some cluster resources that were created during the SQL Server installation.
  3. satya.sqldba New Member

    Hi Satya
    I have tried all different ways mentioned in
    http://msdn2.microsoft.com/en-us/library/ms180973.aspx,

    still it gives me the same error. When you said manually uninstall other services, can I know what are those, and how can I successfully uninstall the instance. Following what's there in BOL isn't helping me.
    Thanks
    Satya

  4. satya.sqldba New Member

    Also when I try to do the following from command prompt:
    %ProgramFiles%Microsoft SQL Server90Setup BootstrapARPWrapper.exe /Remove
    it gives me the error:
    'C:program' is not recognized as an internal or external command,operable program or batch file

    Am I missing something?
  5. satya Moderator

    Check under server's system path whether this program files is defined or not.
    under Control panel --> System and also if possible try to reboot this server and try uninstalling, have you deleted the uninstall log file by chance.
  6. karengonzales New Member

    I have the same problems.. I run the "%ProgramFiles%Microsoft SQL Server90Setup BootstrapARPWrapper.exe /Remove" in cmd and it showed me this message. The directory name is invalid. When I tried to run comman again without double qoute, it showed me this message. The system cannot find the path specified.
  7. satya Moderator

    Karen
    Welcome to the forums.
    WHat are the privileges of the user that are trying to uninstall cluster?
    For solving the above issue, you need to delete the inaccessible volume and create it as new. Since its contents are completely inaccessible, you cannot backup its contents. So, you should restore it from backup. However, if it is unavailable or inaccessible too, you need a solution of windows data recovery.

Share This Page