SQL Server Performance

xpstar.dll issue

Discussion in 'General DBA Questions' started by chetanjain04, Apr 19, 2006.

  1. chetanjain04 Member

    Hi,

    We have a Sql server 2000 SP4 on win2k3 server sp1.

    While backup/restoration of any database system is displaying a message "Error 0 : Cannot load the DLL xpstar.dll, or one of the DLLs it reference, Reason : 5(Access Denied".

    Can any one tell me what is the cause of this and how to resolve this. Is it because of SP4??


    Best Regards,

    Chetan
  2. shekhar157 New Member

  3. satya Moderator

    Are there any changes to the user access which has Administrator privileges recently?
    There could be problem with MDAC tools too, so check with latest security updates on MDAC fromhttp://www.microsoft.com/sql site.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  4. chetanjain04 Member

    Hi,

    Thanks for your reply.

    Just one more question This issue has arisen only after installation of Service Pack4. Is it anywhere related to SP4??? I haven't been able to find anything conclusive on net.

    Regards,

    Chetan
  5. satya Moderator

    I don't think that may be related to that, try reproducing the same on the test environment.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  6. chetanjain04 Member

    Hi Satya,

    Will MDAC install resolve this?? I am not sure. Is there anyway to detect the problem. I have tried several things like replacing the xpstar.dll, service re-start,etc. However, no luck so far.

    Regards,

    Chetan Jain

Share This Page